We have deployed a change to further improve responsiveness, and this incident is now complete.
Posted Jul 16, 2025 - 22:16 UTC
Update
We are continuing to monitor for any further issues.
Posted Jul 16, 2025 - 22:16 UTC
Monitoring
Performance has been restored to normal levels, and we continue to monitor the services.
Posted Jul 16, 2025 - 19:29 UTC
Identified
We have identified overloaded systems and are rectifying them. We are seeing some performance increases and lowered error rate, but we are still working on the issue.
Posted Jul 16, 2025 - 19:00 UTC
Update
We are continuing to investigate this issue.
Posted Jul 16, 2025 - 18:59 UTC
Investigating
We are seeing an increase in error rate and latency in our system, affecting both the UI and the API. We are currently investigating the issue.
Posted Jul 16, 2025 - 18:37 UTC
This incident affected: Routable App (Web Application UI, Routable API).