Increased failures in payment processing

Incident Report for Routable

Resolved

This incident has been resolved.
Posted Nov 18, 2025 - 18:34 UTC

Monitoring

Cloudflare has implemented a fix. We will continue to monitor systems.
Posted Nov 18, 2025 - 14:58 UTC

Update

We are seeing an increase in payment processing failures due to an outage affecting our providers. This is related to the ongoing Cloudflare outage.
Posted Nov 18, 2025 - 14:40 UTC

Identified

We are seeing an increase in payment processing failures due to an outage affecting our providers.
Posted Nov 18, 2025 - 14:08 UTC
This incident affected: Routable App (Web Application UI, Routable API) and Sandbox (Sandbox UI, Sandbox API).