Elevated error rates for payables and vendors

Incident Report for Routable

Resolved

This incident has been resolved.
Posted Jul 13, 2026 - 20:02 UTC

Monitoring

Our provider has implemented a fix, and we see successful transactions. We are monitoring and investigating failed payables.
Posted Jul 13, 2026 - 17:58 UTC

Identified

We are seeing elevated error rates with our payment provider. They are currently investigating.
Posted Jul 13, 2026 - 17:19 UTC
This incident affected: Routable App (Web Application UI, Routable API).