Increased rate of delayed transfers

Incident Report for Routable

Resolved

This incident has been resolved.
Posted Mar 21, 2025 - 23:35 UTC

Monitoring

The system is working again, and we are monitoring for further issues. A small number of payables were impacted and put into Issue status, and the team is working to re-process them.
Posted Mar 21, 2025 - 23:01 UTC

Investigating

Some transfers are delayed due an underlying provider issue. The team is investigating the issue now.
Posted Mar 21, 2025 - 21:49 UTC
This incident affected: Routable App (Web Application UI, Routable API).