Increased failures in payment processing

Incident Report for Routable

Resolved

This incident has been resolved.
Posted Oct 21, 2025 - 17:28 UTC

Monitoring

We are seeing higher levels of success and will keep monitoring as providers report improved service.
Posted Oct 20, 2025 - 23:24 UTC

Identified

We are seeing an increase in payment processing failures due to an outage affecting our providers.
Posted Oct 20, 2025 - 18:47 UTC
This incident affected: Routable App (Web Application UI, Routable API).