We have confirmed that all systems are behaving as expected.
Posted Mar 14, 2025 - 18:25 UTC
Monitoring
There was a period of increased errors and latency in requests to our dashboard and API. Requests are flowing faster now, and we are investigating the cause.
Posted Mar 14, 2025 - 18:05 UTC
This incident affected: Routable App (Web Application UI, Routable API).