Our provider has resolved their issues, and sandbox international payables are working as expected now.
Posted Apr 07, 2026 - 16:30 UTC
Identified
An issue with a provider is resulting in errors for some international vendors and payments in the sandbox environment. Production payments are not affected.
Posted Apr 03, 2026 - 16:26 UTC
This incident affected: Sandbox (Sandbox UI, Sandbox API).