Banking provider issues may result in delays

Incident Report for Routable

Resolved

This incident has been resolved.
Posted Dec 04, 2024 - 22:55 UTC

Investigating

We are experiencing issues with our banking provider that may result in delays in processing as well as the inability to manually add funding sources.
Posted Dec 04, 2024 - 20:29 UTC
This incident affected: Routable App (Web Application UI, Routable API).